Java JDK 8 account sign up

Hello,

On the Capacitor dependencies page it states that for Android, you need to install JDK 8 and that JDK 9 will not work.

They are currently up to JDK 12 and for any of the older version, you need to set up a subscription account.

Something must be up here. Am I missing a free way to download it or am I looking at the wrong software or what?

Any help is appreciated.

Thanks,
Josh

EDIT: I do see that you do not have to pay for the account… but it says that you do for commercial use which I assume that making apps would be. To use with no subscription, you still have to sign up for an account and job title and company name are required. Can we really not use capacitor with a newer version of JDK?