Gradle dependency mismatch in capacitor.build.gradle


#1

All, I have a working iOS app but am now trying to create the Android version.

Gradle is complaining about com.google.android.gms:play-services-basement version needing to be 15.0.1 due to dependencies, but the build was requesting 11.6.2. I have updated several gradle files to support 15.0.1 (15.0.2 actually), but I have now walked back to the capacitor.build.gradle file which is using ‘com.google.firebase:firebase-messaging:11.6.2’. This file is auto-generated so I do not want to edit it. I am on the latest capacitor beta (I believe). Any ideas?


#2

I think the best way of forcing a version it to set it in the App’s build.gradle, that is not overwritten and takes precedence over other gradle files.